2a74944f07
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46427
27 lines
932 B
Diff
27 lines
932 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -534,6 +534,13 @@ config LEDS_PM8941_WLED
|
|
This option enables support for the 'White' LED block
|
|
on Qualcomm PM8941 PMICs.
|
|
|
|
+config LEDS_WNDR3700_USB
|
|
+ tristate "NETGEAR WNDR3700 USB LED driver"
|
|
+ depends on LEDS_CLASS && ATH79_MACH_WNDR3700
|
|
+ help
|
|
+ This option enables support for the USB LED found on the
|
|
+ NETGEAR WNDR3700 board.
|
|
+
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -43,6 +43,7 @@ obj-$(CONFIG_LEDS_DA9052) += leds-da905
|
|
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
|
|
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
|
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
+obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
|
|
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
|
|
obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
|
|
obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o
|