22 lines
772 B
Diff
22 lines
772 B
Diff
--- linux.old/Makefile Tue Oct 10 22:24:41 2006
|
|
+++ linux.dev/Makefile Tue Oct 10 22:26:19 2006
|
|
@@ -427,17 +427,8 @@
|
|
depmod_opts := -b $(INSTALL_MOD_PATH) -r
|
|
endif
|
|
.PHONY: _modinst_post
|
|
-_modinst_post: _modinst_post_pcmcia
|
|
+_modinst_post:
|
|
if [ -r System.map ]; then $(DEPMOD) -ae -F System.map $(depmod_opts) $(KERNELRELEASE); fi
|
|
-
|
|
-# Backwards compatibilty symlinks for people still using old versions
|
|
-# of pcmcia-cs with hard coded pathnames on insmod. Remove
|
|
-# _modinst_post_pcmcia for kernel 2.4.1.
|
|
-.PHONY: _modinst_post_pcmcia
|
|
-_modinst_post_pcmcia:
|
|
- cd $(MODLIB); \
|
|
- mkdir -p pcmcia; \
|
|
- find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
|
|
|
|
.PHONY: $(patsubst %, _modinst_%, $(SUBDIRS))
|
|
$(patsubst %, _modinst_%, $(SUBDIRS)) :
|