b5842aed82
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
88 lines
2.1 KiB
Diff
88 lines
2.1 KiB
Diff
--- a/drivers/base/regmap/Kconfig
|
|
+++ b/drivers/base/regmap/Kconfig
|
|
@@ -3,29 +3,35 @@
|
|
# subsystems should select the appropriate symbols.
|
|
|
|
config REGMAP
|
|
- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_AC97 || REGMAP_MMIO || REGMAP_IRQ)
|
|
select LZO_COMPRESS
|
|
select LZO_DECOMPRESS
|
|
select IRQ_DOMAIN if REGMAP_IRQ
|
|
- bool
|
|
+ tristate "Regmap"
|
|
|
|
config REGMAP_AC97
|
|
+ select REGMAP
|
|
tristate
|
|
|
|
config REGMAP_I2C
|
|
- tristate
|
|
+ tristate "Regmap I2C"
|
|
+ select REGMAP
|
|
depends on I2C
|
|
|
|
config REGMAP_SPI
|
|
- tristate
|
|
+ tristate "Regmap SPI"
|
|
+ select REGMAP
|
|
+ depends on SPI_MASTER
|
|
depends on SPI
|
|
|
|
config REGMAP_SPMI
|
|
+ select REGMAP
|
|
tristate
|
|
depends on SPMI
|
|
|
|
config REGMAP_MMIO
|
|
- tristate
|
|
+ tristate "Regmap MMIO"
|
|
+ select REGMAP
|
|
|
|
config REGMAP_IRQ
|
|
+ select REGMAP
|
|
bool
|
|
--- a/include/linux/regmap.h
|
|
+++ b/include/linux/regmap.h
|
|
@@ -65,7 +65,7 @@ struct reg_sequence {
|
|
unsigned int delay_us;
|
|
};
|
|
|
|
-#ifdef CONFIG_REGMAP
|
|
+#if IS_ENABLED(CONFIG_REGMAP)
|
|
|
|
enum regmap_endian {
|
|
/* Unspecified -> 0 -> Backwards compatible default */
|
|
--- a/drivers/base/regmap/Makefile
|
|
+++ b/drivers/base/regmap/Makefile
|
|
@@ -1,9 +1,11 @@
|
|
# For include/trace/define_trace.h to include trace.h
|
|
CFLAGS_regmap.o := -I$(src)
|
|
|
|
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
|
|
-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
|
|
-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
|
|
+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
|
|
+ifdef CONFIG_DEBUG_FS
|
|
+regmap-core-objs += regmap-debugfs.o
|
|
+endif
|
|
+obj-$(CONFIG_REGMAP) += regmap-core.o
|
|
obj-$(CONFIG_REGMAP_AC97) += regmap-ac97.o
|
|
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
|
|
obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
|
|
--- a/drivers/base/regmap/regmap.c
|
|
+++ b/drivers/base/regmap/regmap.c
|
|
@@ -13,6 +13,7 @@
|
|
#include <linux/device.h>
|
|
#include <linux/slab.h>
|
|
#include <linux/export.h>
|
|
+#include <linux/module.h>
|
|
#include <linux/mutex.h>
|
|
#include <linux/err.h>
|
|
#include <linux/of.h>
|
|
@@ -2852,3 +2853,5 @@ static int __init regmap_initcall(void)
|
|
return 0;
|
|
}
|
|
postcore_initcall(regmap_initcall);
|
|
+
|
|
+MODULE_LICENSE("GPL");
|