d14c28fc80
Refresh patches for all targets that support kernel 4.4. Compile-tested on brcm2708 only. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
23 lines
774 B
Diff
23 lines
774 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -1047,4 +1047,9 @@ config GPIO_NXP_74HC153
|
|
Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
provides a GPIO interface supporting input mode only.
|
|
|
|
+config GPIO_LATCH
|
|
+ tristate "GPIO latch driver"
|
|
+ help
|
|
+ Say yes here to enable a GPIO latch driver.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -47,6 +47,7 @@ obj-$(CONFIG_GPIO_JANZ_TTL) += gpio-janz
|
|
obj-$(CONFIG_GPIO_KEMPLD) += gpio-kempld.o
|
|
obj-$(CONFIG_ARCH_KS8695) += gpio-ks8695.o
|
|
obj-$(CONFIG_GPIO_INTEL_MID) += gpio-intel-mid.o
|
|
+obj-$(CONFIG_GPIO_LATCH) += gpio-latch.o
|
|
obj-$(CONFIG_GPIO_LOONGSON) += gpio-loongson.o
|
|
obj-$(CONFIG_GPIO_LP3943) += gpio-lp3943.o
|
|
obj-$(CONFIG_GPIO_LPC18XX) += gpio-lpc18xx.o
|