6bd1a37001
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39348
12 lines
487 B
Diff
12 lines
487 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -382,7 +382,7 @@ KBUILD_CFLAGS_KERNEL :=
|
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
|
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
|
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
|
|
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|