577f873daf
Signed-off-by: Felix Fietkau <nbd@nbd.name>
22 lines
658 B
Diff
22 lines
658 B
Diff
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -108,4 +108,11 @@ config LEDS_TRIGGER_CAMERA
|
|
This enables direct flash/torch on/off by the driver, kernel space.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|