37fb5ab893
This only removes the patches already applied upstream and makes the rest apply cleanly. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46128
96 lines
2.3 KiB
Diff
96 lines
2.3 KiB
Diff
From 26343bdacfcdbf6ee3303d6078a015b908f90193 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
|
Date: Sat, 16 May 2015 16:55:39 +0200
|
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-AC87U
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts | 65 +++++++++++++++++++++++++++++
|
|
2 files changed, 66 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -66,6 +66,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm47081-asus-rt-n18u.dtb \
|
|
bcm47081-buffalo-wzr-600dhp2.dtb \
|
|
bcm47081-buffalo-wzr-900dhp.dtb \
|
|
+ bcm4709-asus-rt-ac87u.dtb \
|
|
bcm4709-buffalo-wxr-1900dhp.dtb \
|
|
bcm4709-netgear-r8000.dtb
|
|
dtb-$(CONFIG_ARCH_BCM_63XX) += \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
|
@@ -0,0 +1,65 @@
|
|
+/*
|
|
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
|
+ * DTS for Asus RT-AC87U
|
|
+ *
|
|
+ * Copyright (C) 2015 Rafał Miłecki <zajec5@gmail.com>
|
|
+ *
|
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4708.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "asus,rt-ac87u", "brcm,bcm4709", "brcm,bcm4708";
|
|
+ model = "Asus RT-AC87U";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ wps {
|
|
+ label = "bcm53xx:blue:wps";
|
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ power {
|
|
+ label = "bcm53xx:blue:power";
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ wan {
|
|
+ label = "bcm53xx:red:wan";
|
|
+ gpios = <&chipcommon 5 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ wps {
|
|
+ label = "WPS";
|
|
+ linux,code = <KEY_WPS_BUTTON>;
|
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|