cb0c8da7c2
compat-wireless/backports now contains a bcm47xx_nvram.h file to backport some of the functions in it which are used by the bcmfmac driver. This file just checks for the kernel versions and provide an empty implementations on older kernel versions. This is OK on most systems, but on bcm47xx / bcm53xx systems we want to call the real functions here. This commit removes the file from backports in our build process like we do it with the bcma and ssb header files. Instead we add a recent version into our kernel so all code uses only one header file. On bcm47xx / bcm53xx the real implementations of this code will be used. Reported-by: Hante Meuleman <meuleman@broadcom.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47467
58 lines
1.8 KiB
Diff
58 lines
1.8 KiB
Diff
From d7a3d85e08477a979933a2bb3b525a8de99543c2 Mon Sep 17 00:00:00 2001
|
|
From: Jiri Olsa <jolsa@kernel.org>
|
|
Date: Fri, 29 May 2015 17:42:58 +0200
|
|
Subject: [PATCH] perf build: Do not fail on missing Build file
|
|
|
|
Allow nesting into directories without Build file. Currently we force
|
|
include of the Build file, which fails the build when the Build file is
|
|
missing.
|
|
|
|
We already support empty *-in.o' objects if there's nothing in the
|
|
directory to be compiled, so we can just use it for missing Build file
|
|
cases.
|
|
|
|
Also adding this case under tests.
|
|
|
|
Reported-by: Rabin Vincent <rabin.vincent@axis.com>
|
|
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
|
|
Cc: David Ahern <dsahern@gmail.com>
|
|
Cc: Namhyung Kim <namhyung@kernel.org>
|
|
Cc: Paul Mackerras <paulus@samba.org>
|
|
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
|
Cc: Rabin Vincent <rabin.vincent@axis.com>
|
|
Link: http://lkml.kernel.org/r/1432914178-24086-1-git-send-email-jolsa@kernel.org
|
|
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
|
|
---
|
|
tools/build/Makefile.build | 2 +-
|
|
tools/build/tests/ex/Build | 1 +
|
|
tools/build/tests/ex/empty2/README | 2 ++
|
|
3 files changed, 4 insertions(+), 1 deletion(-)
|
|
create mode 100644 tools/build/tests/ex/empty2/README
|
|
|
|
--- a/tools/build/Makefile.build
|
|
+++ b/tools/build/Makefile.build
|
|
@@ -37,7 +37,7 @@ subdir-obj-y :=
|
|
|
|
# Build definitions
|
|
build-file := $(dir)/Build
|
|
-include $(build-file)
|
|
+-include $(build-file)
|
|
|
|
quiet_cmd_flex = FLEX $@
|
|
quiet_cmd_bison = BISON $@
|
|
--- a/tools/build/tests/ex/Build
|
|
+++ b/tools/build/tests/ex/Build
|
|
@@ -2,6 +2,7 @@ ex-y += ex.o
|
|
ex-y += a.o
|
|
ex-y += b.o
|
|
ex-y += empty/
|
|
+ex-y += empty2/
|
|
|
|
libex-y += c.o
|
|
libex-y += d.o
|
|
--- /dev/null
|
|
+++ b/tools/build/tests/ex/empty2/README
|
|
@@ -0,0 +1,2 @@
|
|
+This directory is left intentionally without Build file
|
|
+to test proper nesting into Build-less directories.
|