cc26f768e4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37598
15 lines
340 B
Diff
15 lines
340 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -570,9 +570,9 @@ endif # $(dot-config)
|
|
all: vmlinux
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os -fno-caller-saves
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
|
|
endif
|
|
|
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|