ee16e144bb
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34398
30 lines
909 B
Diff
30 lines
909 B
Diff
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
--- a/arch/mips/ar7/platform.c
|
|
+++ b/arch/mips/ar7/platform.c
|
|
@@ -199,11 +199,14 @@ static struct resource physmap_flash_res
|
|
.name = "mem",
|
|
.flags = IORESOURCE_MEM,
|
|
.start = 0x10000000,
|
|
- .end = 0x107fffff,
|
|
+ .end = 0x11ffffff,
|
|
};
|
|
|
|
+static const char *ar7_probe_types[] = { "ar7part", NULL };
|
|
+
|
|
static struct physmap_flash_data physmap_flash_data = {
|
|
.width = 2,
|
|
+ .part_probe_types = ar7_probe_types,
|
|
};
|
|
|
|
static struct platform_device physmap_flash = {
|