78981f6f3c
SVN-Revision: 20999
26 lines
545 B
Diff
26 lines
545 B
Diff
--- a/crypto/Kconfig
|
|
+++ b/crypto/Kconfig
|
|
@@ -833,6 +833,8 @@ config CRYPTO_ANSI_CPRNG
|
|
ANSI X9.31 A.2.4. Note that this option must be enabled if
|
|
CRYPTO_FIPS is selected
|
|
|
|
+source "crypto/ocf/Kconfig"
|
|
+
|
|
source "drivers/crypto/Kconfig"
|
|
|
|
endif # if CRYPTO
|
|
--- a/crypto/Makefile
|
|
+++ b/crypto/Makefile
|
|
@@ -87,6 +87,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
|
|
obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
|
|
|
|
#
|
|
+# OCF
|
|
+#
|
|
+obj-$(CONFIG_OCF_OCF) += ocf/
|
|
+
|
|
+#
|
|
# generic algorithms and the async_tx api
|
|
#
|
|
obj-$(CONFIG_XOR_BLOCKS) += xor.o
|