3fc661a98c
As usual these patches were extracted from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Also alphabetically order sound-soc kernel packages. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
211 lines
6.1 KiB
Diff
211 lines
6.1 KiB
Diff
From 56a753118a1446feedb1845f37f3e5d3cc4f31a1 Mon Sep 17 00:00:00 2001
|
|
From: Waldemar Brodkorb <wbrodkorb@conet.de>
|
|
Date: Wed, 25 Mar 2015 09:26:17 +0100
|
|
Subject: [PATCH 075/381] Add driver for rpi-proto
|
|
|
|
Forward port of 3.10.x driver from https://github.com/koalo
|
|
We are using a custom board and would like to use rpi 3.18.x
|
|
kernel. Patch works fine for our embedded system.
|
|
|
|
URL to the audio chip:
|
|
http://www.mikroe.com/add-on-boards/audio-voice/audio-codec-proto/
|
|
|
|
Playback tested with devicetree enabled.
|
|
|
|
Signed-off-by: Waldemar Brodkorb <wbrodkorb@conet.de>
|
|
---
|
|
sound/soc/bcm/Kconfig | 7 +++
|
|
sound/soc/bcm/Makefile | 2 +
|
|
sound/soc/bcm/rpi-proto.c | 153 ++++++++++++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 162 insertions(+)
|
|
create mode 100644 sound/soc/bcm/rpi-proto.c
|
|
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -43,6 +43,13 @@ config SND_BCM2708_SOC_RPI_DAC
|
|
help
|
|
Say Y or M if you want to add support for RPi-DAC.
|
|
|
|
+config SND_BCM2708_SOC_RPI_PROTO
|
|
+ tristate "Support for Rpi-PROTO"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_WM8731
|
|
+ help
|
|
+ Say Y or M if you want to add support for Audio Codec Board PROTO (WM8731).
|
|
+
|
|
config SND_BCM2708_SOC_IQAUDIO_DAC
|
|
tristate "Support for IQaudIO-DAC"
|
|
depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -9,6 +9,7 @@ snd-soc-hifiberry-dacplus-objs := hifibe
|
|
snd-soc-hifiberry-digi-objs := hifiberry_digi.o
|
|
snd-soc-hifiberry-amp-objs := hifiberry_amp.o
|
|
snd-soc-rpi-dac-objs := rpi-dac.o
|
|
+snd-soc-rpi-proto-objs := rpi-proto.o
|
|
snd-soc-iqaudio-dac-objs := iqaudio-dac.o
|
|
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
|
|
@@ -16,4 +17,5 @@ obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_D
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DIGI) += snd-soc-hifiberry-digi.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_AMP) += snd-soc-hifiberry-amp.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) += snd-soc-rpi-dac.o
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_RPI_PROTO) += snd-soc-rpi-proto.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) += snd-soc-iqaudio-dac.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/rpi-proto.c
|
|
@@ -0,0 +1,153 @@
|
|
+/*
|
|
+ * ASoC driver for PROTO AudioCODEC (with a WM8731)
|
|
+ * connected to a Raspberry Pi
|
|
+ *
|
|
+ * Author: Florian Meier, <koalo@koalo.de>
|
|
+ * Copyright 2013
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+#include "../codecs/wm8731.h"
|
|
+
|
|
+static const unsigned int wm8731_rates_12288000[] = {
|
|
+ 8000, 32000, 48000, 96000,
|
|
+};
|
|
+
|
|
+static struct snd_pcm_hw_constraint_list wm8731_constraints_12288000 = {
|
|
+ .list = wm8731_rates_12288000,
|
|
+ .count = ARRAY_SIZE(wm8731_rates_12288000),
|
|
+};
|
|
+
|
|
+static int snd_rpi_proto_startup(struct snd_pcm_substream *substream)
|
|
+{
|
|
+ /* Setup constraints, because there is a 12.288 MHz XTAL on the board */
|
|
+ snd_pcm_hw_constraint_list(substream->runtime, 0,
|
|
+ SNDRV_PCM_HW_PARAM_RATE,
|
|
+ &wm8731_constraints_12288000);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int snd_rpi_proto_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+ int sysclk = 12288000; /* This is fixed on this board */
|
|
+
|
|
+ /* Set proto bclk */
|
|
+ int ret = snd_soc_dai_set_bclk_ratio(cpu_dai,32*2);
|
|
+ if (ret < 0){
|
|
+ dev_err(codec->dev,
|
|
+ "Failed to set BCLK ratio %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ /* Set proto sysclk */
|
|
+ ret = snd_soc_dai_set_sysclk(codec_dai, WM8731_SYSCLK_XTAL,
|
|
+ sysclk, SND_SOC_CLOCK_IN);
|
|
+ if (ret < 0) {
|
|
+ dev_err(codec->dev,
|
|
+ "Failed to set WM8731 SYSCLK: %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_proto_ops = {
|
|
+ .startup = snd_rpi_proto_startup,
|
|
+ .hw_params = snd_rpi_proto_hw_params,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_proto_dai[] = {
|
|
+{
|
|
+ .name = "WM8731",
|
|
+ .stream_name = "WM8731 HiFi",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "wm8731-hifi",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "wm8731.1-001a",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S
|
|
+ | SND_SOC_DAIFMT_NB_NF
|
|
+ | SND_SOC_DAIFMT_CBM_CFM,
|
|
+ .ops = &snd_rpi_proto_ops,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_proto = {
|
|
+ .name = "snd_rpi_proto",
|
|
+ .dai_link = snd_rpi_proto_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_proto_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_proto_probe(struct platform_device *pdev)
|
|
+{
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_rpi_proto.dev = &pdev->dev;
|
|
+
|
|
+ if (pdev->dev.of_node) {
|
|
+ struct device_node *i2s_node;
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_proto_dai[0];
|
|
+ i2s_node = of_parse_phandle(pdev->dev.of_node,
|
|
+ "i2s-controller", 0);
|
|
+
|
|
+ if (i2s_node) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_node;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_node;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_rpi_proto);
|
|
+ if (ret) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "snd_soc_register_card() failed: %d\n", ret);
|
|
+ }
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+
|
|
+static int snd_rpi_proto_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_rpi_proto);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_rpi_proto_of_match[] = {
|
|
+ { .compatible = "rpi,rpi-proto", },
|
|
+ {},
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, snd_rpi_proto_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_proto_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-rpi-proto",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_rpi_proto_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_proto_probe,
|
|
+ .remove = snd_rpi_proto_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_proto_driver);
|
|
+
|
|
+MODULE_AUTHOR("Florian Meier");
|
|
+MODULE_DESCRIPTION("ASoC Driver for Raspberry Pi connected to PROTO board (WM8731)");
|
|
+MODULE_LICENSE("GPL");
|