openwrt/target/linux/ramips/patches-2.6.30/104-watchdog.patch

31 lines
1.1 KiB
Diff

Index: linux-2.6.30.5/drivers/watchdog/Kconfig
===================================================================
--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
+++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-04 15:19:34.000000000 +0200
@@ -764,6 +764,13 @@
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+config RAMIPS_WDT
+ tristate "Ralink Watchdog Timer"
+ depends on MIPS_RALINK
+ help
+ Hardware driver for the built-in watchdog timer on Ralink MIPS SoCs.
+
+
# PARISC Architecture
# POWERPC Architecture
Index: linux-2.6.30.5/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
+++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-04 15:19:34.000000000 +0200
@@ -105,6 +105,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+obj-$(CONFIG_RAMIPS_WDT) += ramipswdt.o
# PARISC Architecture