a0c49ef46f
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
46 lines
1.3 KiB
Diff
46 lines
1.3 KiB
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -251,6 +251,30 @@ config MDIO_BCM_UNIMAC
|
|
controllers as well as some Broadcom Ethernet switches such as the
|
|
Starfighter 2 switches.
|
|
|
|
+config RTL8366_SMI
|
|
+ tristate "Driver for the RTL8366 SMI interface"
|
|
+ depends on GPIOLIB
|
|
+ ---help---
|
|
+ This module implements the SMI interface protocol which is used
|
|
+ by some RTL8366 ethernet switch devices via the generic GPIO API.
|
|
+
|
|
+if RTL8366_SMI
|
|
+
|
|
+config RTL8366_SMI_DEBUG_FS
|
|
+ bool "RTL8366 SMI interface debugfs support"
|
|
+ depends on DEBUG_FS
|
|
+ default n
|
|
+
|
|
+config RTL8366S_PHY
|
|
+ tristate "Driver for the Realtek RTL8366S switch"
|
|
+ select SWCONFIG
|
|
+
|
|
+config RTL8366RB_PHY
|
|
+ tristate "Driver for the Realtek RTL8366RB switch"
|
|
+ select SWCONFIG
|
|
+
|
|
+endif # RTL8366_SMI
|
|
+
|
|
endif # PHYLIB
|
|
|
|
config MICREL_KS8995MA
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -24,6 +24,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
|
|
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
|
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
|
|
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
|
|
+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|