a0c49ef46f
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
29 lines
824 B
Diff
29 lines
824 B
Diff
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -108,4 +108,8 @@ config LEDS_TRIGGER_CAMERA
|
|
This enables direct flash/torch on/off by the driver, kernel space.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_MORSE
|
|
+ tristate "LED Morse Trigger"
|
|
+ depends on LEDS_TRIGGERS
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
--- a/drivers/leds/ledtrig-morse.c
|
|
+++ b/drivers/leds/ledtrig-morse.c
|
|
@@ -26,7 +26,6 @@
|
|
#include <linux/list.h>
|
|
#include <linux/spinlock.h>
|
|
#include <linux/device.h>
|
|
-#include <linux/sysdev.h>
|
|
#include <linux/timer.h>
|
|
#include <linux/ctype.h>
|
|
#include <linux/leds.h>
|