73c4d73d6d
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37600
15 lines
348 B
Diff
15 lines
348 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -570,9 +570,9 @@ endif # $(dot-config)
|
|
all: vmlinux
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
|
|
endif
|
|
|
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|