f4f553efa7
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40852
12 lines
635 B
Diff
12 lines
635 B
Diff
--- a/Makefile.flags
|
|
+++ b/Makefile.flags
|
|
@@ -51,7 +51,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
|
|
# -fno-guess-branch-probability: prohibit pseudo-random guessing
|
|
# of branch probabilities (hopefully makes bloatcheck more stable):
|
|
CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
|
|
-CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
|
|
+CFLAGS += $(call cc-option,-funsigned-char,)
|
|
CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
|
|
# Defeat .eh_frame bloat (gcc 4.6.3 x86-32 defconfig: 20% smaller busybox binary):
|
|
CFLAGS += $(call cc-option,-fno-unwind-tables,)
|