740ed0ede4
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 40778
14 lines
380 B
Diff
14 lines
380 B
Diff
--- a/tools/env/Makefile
|
|
+++ b/tools/env/Makefile
|
|
@@ -10,6 +10,10 @@
|
|
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
|
|
HOSTCC = $(CC)
|
|
|
|
+ifneq ($(TARGET_CFLAGS),)
|
|
+HOSTCFLAGS = $(TARGET_CFLAGS)
|
|
+endif
|
|
+
|
|
# Compile for a hosted environment on the target
|
|
HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
|
|
-idirafter $(srctree)/tools/env \
|