f2c1e05f37
SVN-Revision: 17665
43 lines
1.3 KiB
Diff
43 lines
1.3 KiB
Diff
From 2f5ce947444bafc565d67b7f14316becda441b24 Mon Sep 17 00:00:00 2001
|
|
From: Lars-Peter Clausen <lars@metafoo.de>
|
|
Date: Tue, 21 Jul 2009 12:46:35 +0200
|
|
Subject: [PATCH] 055-gta02-leds.patch
|
|
|
|
---
|
|
drivers/leds/Kconfig | 13 +++++++++++++
|
|
drivers/leds/Makefile | 2 ++
|
|
2 files changed, 15 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/drivers/leds/Kconfig b/drivers/leds/Kconfig
|
|
index 7c8e712..9960398 100644
|
|
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -229,6 +229,12 @@ config LEDS_BD2802
|
|
This option enables support for BD2802GU RGB LED driver chips
|
|
accessed via the I2C bus.
|
|
|
|
+config LEDS_GTA02_VIBRATOR
|
|
+ tristate "Vibrator Support for the Openmoko Freerunner GSM phone"
|
|
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
|
+ help
|
|
+ This option enables support for the vibrator on the Openmoko Freerunner.
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGERS
|
|
diff --git a/drivers/leds/Makefile b/drivers/leds/Makefile
|
|
index e8cdcf7..ff4a6d7 100644
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -31,6 +31,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
|
+obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
|
|
--
|
|
1.5.6.5
|
|
|