e553dfc356
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
31 lines
953 B
Diff
31 lines
953 B
Diff
Index: linux-3.14.18/drivers/ata/Kconfig
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/ata/Kconfig
|
|
+++ linux-3.14.18/drivers/ata/Kconfig
|
|
@@ -330,6 +330,13 @@ config SATA_VITESSE
|
|
|
|
If unsure, say N.
|
|
|
|
+config SATA_OXNAS
|
|
+ tristate "PLXTECH NAS782X SATA support"
|
|
+ help
|
|
+ This option enables support for Nas782x Serial ATA controller.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
comment "PATA SFF controllers with BMDMA"
|
|
|
|
config PATA_ALI
|
|
Index: linux-3.14.18/drivers/ata/Makefile
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/ata/Makefile
|
|
+++ linux-3.14.18/drivers/ata/Makefile
|
|
@@ -31,6 +31,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
|
|
obj-$(CONFIG_SATA_ULI) += sata_uli.o
|
|
obj-$(CONFIG_SATA_VIA) += sata_via.o
|
|
obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
|
|
+obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
|
|
|
|
# SFF PATA w/ BMDMA
|
|
obj-$(CONFIG_PATA_ALI) += pata_ali.o
|