c05048b0bb
This adds support for the oxnas target in U-Boot 2014.04 History can be found at https://github.com/kref/u-boot-oxnas up to 2013.10 changes from 2013.10 to 2014.04 can be followed at https://gitorious.org/openwrt-oxnas Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43389
100 lines
5.6 KiB
Diff
100 lines
5.6 KiB
Diff
--- a/arch/arm/include/asm/mach-types.h
|
|
+++ b/arch/arm/include/asm/mach-types.h
|
|
@@ -212,6 +212,7 @@ extern unsigned int __machine_arch_type;
|
|
#define MACH_TYPE_EDB9307A 1128
|
|
#define MACH_TYPE_OMAP_3430SDP 1138
|
|
#define MACH_TYPE_VSTMS 1140
|
|
+#define MACH_TYPE_OXNAS 1152
|
|
#define MACH_TYPE_MICRO9M 1169
|
|
#define MACH_TYPE_BUG 1179
|
|
#define MACH_TYPE_AT91SAM9263EK 1202
|
|
--- a/boards.cfg
|
|
+++ b/boards.cfg
|
|
@@ -57,6 +57,11 @@ Active arm arm1136 mx35
|
|
Active arm arm1136 mx35 - woodburn woodburn_sd woodburn_sd:IMX_CONFIG=board/woodburn/imximage.cfg -
|
|
Active arm arm1136 mx35 CarMediaLab - flea3 - Stefano Babic <sbabic@denx.de>
|
|
Active arm arm1136 mx35 freescale - mx35pdk - Stefano Babic <sbabic@denx.de>
|
|
+Active arm arm1136 nas782x - - ox820 - -
|
|
+Active arm arm1136 nas782x - nas782x ox820_sata ox820:BOOT_FROM_SATA -
|
|
+Active arm arm1136 nas782x - nas782x ox820_fat ox820:BOOT_FROM_SATA,BOOT_FROM_FAT
|
|
+Active arm arm1136 nas782x - nas782x ox820_ext4 ox820:BOOT_FROM_SATA,BOOT_FROM_EXT4 -
|
|
+Active arm arm1136 nas782x - nas782x ox820_nand ox820:BOOT_FROM_NAND -
|
|
Active arm arm1176 bcm2835 raspberrypi rpi_b rpi_b - Stephen Warren <swarren@wwwdotorg.org>
|
|
Active arm arm1176 tnetv107x ti tnetv107xevm tnetv107x_evm - Chan-Taek Park <c-park@ti.com>
|
|
Active arm arm720t - armltd integrator integratorap_cm720t integratorap:CM720T Linus Walleij <linus.walleij@linaro.org>
|
|
--- a/drivers/block/Makefile
|
|
+++ b/drivers/block/Makefile
|
|
@@ -21,3 +21,4 @@ obj-$(CONFIG_IDE_SIL680) += sil680.o
|
|
obj-$(CONFIG_SANDBOX) += sandbox.o
|
|
obj-$(CONFIG_SCSI_SYM53C8XX) += sym53c8xx.o
|
|
obj-$(CONFIG_SYSTEMACE) += systemace.o
|
|
+obj-$(CONFIG_IDE_PLX) += plxsata_ide.o
|
|
--- a/drivers/serial/serial_ns16550.c
|
|
+++ b/drivers/serial/serial_ns16550.c
|
|
@@ -135,6 +135,14 @@ static int calc_divisor (NS16550_t port)
|
|
}
|
|
#endif
|
|
|
|
+#ifdef CONFIG_OX820
|
|
+ {
|
|
+ /* with additional 3 bit fractional */
|
|
+ u32 div = (CONFIG_SYS_NS16550_CLK + gd->baudrate) / (gd->baudrate * 2);
|
|
+ port->reg9 = (div & 7) << 5;
|
|
+ return (div >> 3);
|
|
+ }
|
|
+#endif
|
|
#define MODE_X_DIV 16
|
|
/* Compute divisor value. Normally, we should simply return:
|
|
* CONFIG_SYS_NS16550_CLK) / MODE_X_DIV / gd->baudrate
|
|
--- a/drivers/usb/host/Makefile
|
|
+++ b/drivers/usb/host/Makefile
|
|
@@ -32,6 +32,7 @@ obj-$(CONFIG_USB_EHCI_MX6) += ehci-mx6.o
|
|
obj-$(CONFIG_USB_EHCI_OMAP) += ehci-omap.o
|
|
obj-$(CONFIG_USB_EHCI_PPC4XX) += ehci-ppc4xx.o
|
|
obj-$(CONFIG_USB_EHCI_MARVELL) += ehci-marvell.o
|
|
+obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
|
|
obj-$(CONFIG_USB_EHCI_PCI) += ehci-pci.o
|
|
obj-$(CONFIG_USB_EHCI_SPEAR) += ehci-spear.o
|
|
obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
|
|
--- a/spl/Makefile
|
|
+++ b/spl/Makefile
|
|
@@ -207,8 +207,13 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
|
|
|
|
OBJCOPYFLAGS_$(SPL_BIN).bin = $(SPL_OBJCFLAGS) -O binary
|
|
|
|
+ifdef CONFIG_OX820
|
|
$(obj)/$(SPL_BIN).bin: $(obj)/$(SPL_BIN) FORCE
|
|
$(call if_changed,objcopy)
|
|
+ $(OBJTREE)/tools/mkox820crc $@
|
|
+else
|
|
+ $(call if_changed,objcopy)
|
|
+endef
|
|
|
|
LDFLAGS_$(SPL_BIN) += -T u-boot-spl.lds $(LDFLAGS_FINAL)
|
|
ifneq ($(CONFIG_SPL_TEXT_BASE),)
|
|
--- a/tools/.gitignore
|
|
+++ b/tools/.gitignore
|
|
@@ -7,6 +7,7 @@
|
|
/mkenvimage
|
|
/mkimage
|
|
/mkexynosspl
|
|
+/mkox820crc
|
|
/mpc86x_clk
|
|
/mxsboot
|
|
/ncb
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -131,6 +131,12 @@ hostprogs-$(CONFIG_KIRKWOOD) += kwboot$(
|
|
hostprogs-y += proftool$(SFX)
|
|
hostprogs-$(CONFIG_STATIC_RELA) += relocate-rela$(SFX)
|
|
|
|
+
|
|
+hostprogs-$(CONFIG_OX820) += mkox820crc$(SFX)
|
|
+
|
|
+mkox820crc$(SFX)-objs := mkox820crc.o crc32.o
|
|
+
|
|
+
|
|
# We build some files with extra pedantic flags to try to minimize things
|
|
# that won't build on some weird host compiler -- though there are lots of
|
|
# exceptions for files that aren't complaint.
|