37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From 89b43d59ec8c9cda588555eb1f2754dd19ef5144 Mon Sep 17 00:00:00 2001
|
|
From: Christian Lamparter <chunkeey@gmail.com>
|
|
Date: Sun, 22 Jul 2018 12:07:57 +0200
|
|
Subject: [PATCH 8/8] ARM: qcom: Add IPQ4019 SoC support
|
|
|
|
Add support for the Qualcomm Atheros IPQ4019 SoC.
|
|
|
|
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/Makefile | 1 +
|
|
arch/arm/mach-qcom/Kconfig | 5 +++++
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/arch/arm/Makefile
|
|
+++ b/arch/arm/Makefile
|
|
@@ -150,6 +150,7 @@ endif
|
|
textofs-$(CONFIG_ARCH_MSM8X60) := 0x00208000
|
|
textofs-$(CONFIG_ARCH_MSM8960) := 0x00208000
|
|
textofs-$(CONFIG_ARCH_AXXIA) := 0x00308000
|
|
+textofs-$(CONFIG_ARCH_IPQ40XX) := 0x00208000
|
|
|
|
# Machine directory name. This list is sorted alphanumerically
|
|
# by CONFIG_* macro name.
|
|
--- a/arch/arm/mach-qcom/Kconfig
|
|
+++ b/arch/arm/mach-qcom/Kconfig
|
|
@@ -27,4 +27,9 @@ config ARCH_MDM9615
|
|
bool "Enable support for MDM9615"
|
|
select CLKSRC_QCOM
|
|
|
|
+config ARCH_IPQ40XX
|
|
+ bool "Enable support for IPQ40XX"
|
|
+ select CLKSRC_QCOM
|
|
+ select HAVE_ARM_ARCH_TIMER
|
|
+
|
|
endif
|