2530640f07
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48563
26 lines
789 B
Diff
26 lines
789 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -1039,4 +1039,12 @@ config GPIO_VIPERBOARD
|
|
|
|
endmenu
|
|
|
|
+comment "Other GPIO expanders"
|
|
+
|
|
+config GPIO_NXP_74HC153
|
|
+ tristate "NXP 74HC153 Dual 4-input multiplexer"
|
|
+ help
|
|
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
+ provides a GPIO interface supporting input mode only.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -69,6 +69,7 @@ obj-$(CONFIG_GPIO_MSIC) += gpio-msic.o
|
|
obj-$(CONFIG_GPIO_MVEBU) += gpio-mvebu.o
|
|
obj-$(CONFIG_GPIO_MXC) += gpio-mxc.o
|
|
obj-$(CONFIG_GPIO_MXS) += gpio-mxs.o
|
|
+obj-$(CONFIG_GPIO_NXP_74HC153) += gpio-nxp-74hc153.o
|
|
obj-$(CONFIG_GPIO_OCTEON) += gpio-octeon.o
|
|
obj-$(CONFIG_GPIO_OMAP) += gpio-omap.o
|
|
obj-$(CONFIG_GPIO_PCA953X) += gpio-pca953x.o
|