72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
31 lines
959 B
Diff
31 lines
959 B
Diff
Index: linux-3.18-rc4/drivers/ata/Kconfig
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/ata/Kconfig
|
|
+++ linux-3.18-rc4/drivers/ata/Kconfig
|
|
@@ -385,6 +385,13 @@ config SATA_VITESSE
|
|
|
|
If unsure, say N.
|
|
|
|
+config SATA_OXNAS
|
|
+ tristate "PLXTECH NAS782X SATA support"
|
|
+ help
|
|
+ This option enables support for Nas782x Serial ATA controller.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
comment "PATA SFF controllers with BMDMA"
|
|
|
|
config PATA_ALI
|
|
Index: linux-3.18-rc4/drivers/ata/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/drivers/ata/Makefile
|
|
+++ linux-3.18-rc4/drivers/ata/Makefile
|
|
@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
|
|
obj-$(CONFIG_SATA_ULI) += sata_uli.o
|
|
obj-$(CONFIG_SATA_VIA) += sata_via.o
|
|
obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
|
|
+obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
|
|
|
|
# SFF PATA w/ BMDMA
|
|
obj-$(CONFIG_PATA_ALI) += pata_ali.o
|