76d079204d
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
126 lines
3.0 KiB
Diff
126 lines
3.0 KiB
Diff
From 16dc3bac722252a10e396546f44135ae1b6a7ff3 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
|
Date: Tue, 31 Mar 2015 17:29:18 +0200
|
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-AC56U
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts | 96 +++++++++++++++++++++++++++++
|
|
2 files changed, 97 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -55,6 +55,7 @@ dtb-$(CONFIG_ARCH_ATLAS6) += atlas6-evb.
|
|
dtb-$(CONFIG_ARCH_AXXIA) += axm5516-amarillo.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
+ bcm4708-asus-rt-ac56u.dtb \
|
|
bcm4708-asus-rt-ac68u.dtb \
|
|
bcm4708-buffalo-wzr-1750dhp.dtb \
|
|
bcm4708-luxul-xwc-1000.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm4708-asus-rt-ac56u.dts
|
|
@@ -0,0 +1,96 @@
|
|
+/*
|
|
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
|
+ * DTS for Asus RT-AC56U
|
|
+ *
|
|
+ * Copyright (C) 2015 Rafał Miłecki <zajec5@gmail.com>
|
|
+ *
|
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4708.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "asus,rt-ac56u", "brcm,bcm4708";
|
|
+ model = "Asus RT-AC56U (BCM4708)";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x08000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ usb3 {
|
|
+ label = "bcm53xx:blue:usb3";
|
|
+ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ wan {
|
|
+ label = "bcm53xx:blue:wan";
|
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ lan {
|
|
+ label = "bcm53xx:blue:lan";
|
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+ power {
|
|
+ label = "bcm53xx:blue:power";
|
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ all {
|
|
+ label = "bcm53xx:blue:all";
|
|
+ gpios = <&chipcommon 4 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ 2ghz {
|
|
+ label = "bcm53xx:blue:2ghz";
|
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+
|
|
+
|
|
+ usb2 {
|
|
+ label = "bcm53xx:blue:usb2";
|
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "default-off";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ rfkill {
|
|
+ label = "WiFi";
|
|
+ linux,code = <KEY_RFKILL>;
|
|
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ wps {
|
|
+ label = "WPS";
|
|
+ linux,code = <KEY_WPS_BUTTON>;
|
|
+ gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|