89d37aaa5c
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 48339
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
|
|
+++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
|
|
@@ -69,6 +69,16 @@ config DWMAC_MESON
|
|
the stmmac device driver. This driver is used for Meson6 and
|
|
Meson8 SoCs.
|
|
|
|
+config DWMAC_OXNAS
|
|
+ tristate "Oxnas gmac support"
|
|
+ default ARCH_OXNAS
|
|
+ depends on OF && ARCH_OXNAS
|
|
+ help
|
|
+ Support for Ethernet controller on Oxnas SoCs.
|
|
+
|
|
+ This selects the Oxford OX82x SoC glue layer support for
|
|
+ the stmmac device driver.
|
|
+
|
|
config DWMAC_ROCKCHIP
|
|
tristate "Rockchip dwmac support"
|
|
default ARCH_ROCKCHIP
|
|
--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
|
|
+++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
|
|
@@ -9,6 +9,7 @@ obj-$(CONFIG_STMMAC_PLATFORM) += stmmac-
|
|
obj-$(CONFIG_DWMAC_IPQ806X) += dwmac-ipq806x.o
|
|
obj-$(CONFIG_DWMAC_LPC18XX) += dwmac-lpc18xx.o
|
|
obj-$(CONFIG_DWMAC_MESON) += dwmac-meson.o
|
|
+obj-$(CONFIG_DWMAC_OXNAS) += dwmac-oxnas.o
|
|
obj-$(CONFIG_DWMAC_ROCKCHIP) += dwmac-rk.o
|
|
obj-$(CONFIG_DWMAC_SOCFPGA) += dwmac-socfpga.o
|
|
obj-$(CONFIG_DWMAC_STI) += dwmac-sti.o
|