1630498e4c
Those don't exist anymore. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 45314
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -184,6 +184,22 @@ config MTD_BCM47XX_PARTS
|
|
This provides partitions parser for devices based on BCM47xx
|
|
boards.
|
|
|
|
+config MTD_MYLOADER_PARTS
|
|
+ tristate "MyLoader partition parsing"
|
|
+ depends on ADM5120 || ATH25 || ATH79
|
|
+ ---help---
|
|
+ MyLoader is a bootloader which allows the user to define partitions
|
|
+ in flash devices, by putting a table in the second erase block
|
|
+ on the device, similar to a partition table. This table gives the
|
|
+ offsets and lengths of the user defined partitions.
|
|
+
|
|
+ If you need code which can detect and parse these tables, and
|
|
+ register MTD 'partitions' corresponding to each image detected,
|
|
+ enable this option.
|
|
+
|
|
+ You will still need the parsing functions to be called by the driver
|
|
+ for your particular device. It won't happen automatically.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
#
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
|
|
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o
|