84d489f64f
Changelog: https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.14 Some manual changes to target/linux/generic/patches-4.4/610- netfilter_match_bypass_default_checks.patch were needed. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
145 lines
4.8 KiB
Diff
145 lines
4.8 KiB
Diff
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [v3,01/13] ARM: Add Krait L2 register accessor functions
|
|
From: Stephen Boyd <sboyd@codeaurora.org>
|
|
X-Patchwork-Id: 6063051
|
|
Message-Id: <1426920332-9340-2-git-send-email-sboyd@codeaurora.org>
|
|
To: Mike Turquette <mturquette@linaro.org>, Stephen Boyd <sboyd@codeaurora.org>
|
|
Cc: linux-kernel@vger.kernel.org, linux-arm-msm@vger.kernel.org,
|
|
linux-pm@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
|
Viresh Kumar <viresh.kumar@linaro.org>,
|
|
Mark Rutland <mark.rutland@arm.com>, Russell King <linux@arm.linux.org.uk>,
|
|
Courtney Cavin <courtney.cavin@sonymobile.com>
|
|
Date: Fri, 20 Mar 2015 23:45:20 -0700
|
|
|
|
Krait CPUs have a handful of L2 cache controller registers that
|
|
live behind a cp15 based indirection register. First you program
|
|
the indirection register (l2cpselr) to point the L2 'window'
|
|
register (l2cpdr) at what you want to read/write. Then you
|
|
read/write the 'window' register to do what you want. The
|
|
l2cpselr register is not banked per-cpu so we must lock around
|
|
accesses to it to prevent other CPUs from re-pointing l2cpdr
|
|
underneath us.
|
|
|
|
Cc: Mark Rutland <mark.rutland@arm.com>
|
|
Cc: Russell King <linux@arm.linux.org.uk>
|
|
Cc: Courtney Cavin <courtney.cavin@sonymobile.com>
|
|
Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
|
|
|
|
---
|
|
arch/arm/common/Kconfig | 3 ++
|
|
arch/arm/common/Makefile | 1 +
|
|
arch/arm/common/krait-l2-accessors.c | 58 +++++++++++++++++++++++++++++++
|
|
arch/arm/include/asm/krait-l2-accessors.h | 20 +++++++++++
|
|
4 files changed, 82 insertions(+)
|
|
create mode 100644 arch/arm/common/krait-l2-accessors.c
|
|
create mode 100644 arch/arm/include/asm/krait-l2-accessors.h
|
|
|
|
--- a/arch/arm/common/Kconfig
|
|
+++ b/arch/arm/common/Kconfig
|
|
@@ -9,6 +9,9 @@ config DMABOUNCE
|
|
bool
|
|
select ZONE_DMA
|
|
|
|
+config KRAIT_L2_ACCESSORS
|
|
+ bool
|
|
+
|
|
config SHARP_LOCOMO
|
|
bool
|
|
|
|
--- a/arch/arm/common/Makefile
|
|
+++ b/arch/arm/common/Makefile
|
|
@@ -7,6 +7,7 @@ obj-y += firmware.o
|
|
obj-$(CONFIG_ICST) += icst.o
|
|
obj-$(CONFIG_SA1111) += sa1111.o
|
|
obj-$(CONFIG_DMABOUNCE) += dmabounce.o
|
|
+obj-$(CONFIG_KRAIT_L2_ACCESSORS) += krait-l2-accessors.o
|
|
obj-$(CONFIG_SHARP_LOCOMO) += locomo.o
|
|
obj-$(CONFIG_SHARP_PARAM) += sharpsl_param.o
|
|
obj-$(CONFIG_SHARP_SCOOP) += scoop.o
|
|
--- /dev/null
|
|
+++ b/arch/arm/common/krait-l2-accessors.c
|
|
@@ -0,0 +1,58 @@
|
|
+/*
|
|
+ * Copyright (c) 2011-2013, The Linux Foundation. All rights reserved.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 and
|
|
+ * only version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/spinlock.h>
|
|
+#include <linux/export.h>
|
|
+
|
|
+#include <asm/barrier.h>
|
|
+#include <asm/krait-l2-accessors.h>
|
|
+
|
|
+static DEFINE_RAW_SPINLOCK(krait_l2_lock);
|
|
+
|
|
+void krait_set_l2_indirect_reg(u32 addr, u32 val)
|
|
+{
|
|
+ unsigned long flags;
|
|
+
|
|
+ raw_spin_lock_irqsave(&krait_l2_lock, flags);
|
|
+ /*
|
|
+ * Select the L2 window by poking l2cpselr, then write to the window
|
|
+ * via l2cpdr.
|
|
+ */
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 6 @ l2cpselr" : : "r" (addr));
|
|
+ isb();
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 7 @ l2cpdr" : : "r" (val));
|
|
+ isb();
|
|
+
|
|
+ raw_spin_unlock_irqrestore(&krait_l2_lock, flags);
|
|
+}
|
|
+EXPORT_SYMBOL(krait_set_l2_indirect_reg);
|
|
+
|
|
+u32 krait_get_l2_indirect_reg(u32 addr)
|
|
+{
|
|
+ u32 val;
|
|
+ unsigned long flags;
|
|
+
|
|
+ raw_spin_lock_irqsave(&krait_l2_lock, flags);
|
|
+ /*
|
|
+ * Select the L2 window by poking l2cpselr, then read from the window
|
|
+ * via l2cpdr.
|
|
+ */
|
|
+ asm volatile ("mcr p15, 3, %0, c15, c0, 6 @ l2cpselr" : : "r" (addr));
|
|
+ isb();
|
|
+ asm volatile ("mrc p15, 3, %0, c15, c0, 7 @ l2cpdr" : "=r" (val));
|
|
+
|
|
+ raw_spin_unlock_irqrestore(&krait_l2_lock, flags);
|
|
+
|
|
+ return val;
|
|
+}
|
|
+EXPORT_SYMBOL(krait_get_l2_indirect_reg);
|
|
--- /dev/null
|
|
+++ b/arch/arm/include/asm/krait-l2-accessors.h
|
|
@@ -0,0 +1,20 @@
|
|
+/*
|
|
+ * Copyright (c) 2011-2013, The Linux Foundation. All rights reserved.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 and
|
|
+ * only version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ */
|
|
+
|
|
+#ifndef __ASMARM_KRAIT_L2_ACCESSORS_H
|
|
+#define __ASMARM_KRAIT_L2_ACCESSORS_H
|
|
+
|
|
+extern void krait_set_l2_indirect_reg(u32 addr, u32 val);
|
|
+extern u32 krait_get_l2_indirect_reg(u32 addr);
|
|
+
|
|
+#endif
|