Change dhcp-forwarder packaging
SVN-Revision: 488
This commit is contained in:
parent
9038faa018
commit
59907257f5
@ -7,12 +7,13 @@ PKG_VERSION := 0.7
|
||||
PKG_RELEASE := 4
|
||||
PKG_MD5SUM := e7f876e615ebc3f96418f6477b4451e2
|
||||
|
||||
PKG_SOURCE_SITE := http://savannah.nongnu.org/download/dhcp-fwd/
|
||||
PKG_SOURCE_SITE := http://savannah.nongnu.org/download/dhcp-fwd/ \
|
||||
http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
|
||||
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_CAT := bzcat
|
||||
PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
|
||||
PKG_IPK := $(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
|
||||
PKG_IPK := $(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
|
||||
|
||||
$(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||
mkdir -p $(DL_DIR)
|
||||
@ -21,28 +22,28 @@ $(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||
$(PKG_BUILD_DIR)/ipkg/rules: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
mkdir -p $(TOOL_BUILD_DIR)
|
||||
$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(PATCH) $(PKG_BUILD_DIR) . $(PKG_NAME)-\*.diff
|
||||
# $(PATCH) $(PKG_BUILD_DIR) ./patches
|
||||
cp -fpR ./ipkg $(PKG_BUILD_DIR)/
|
||||
chmod a+x $(PKG_BUILD_DIR)/ipkg/rules
|
||||
touch $(PKG_BUILD_DIR)/ipkg/rules
|
||||
|
||||
$(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
|
||||
cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
package
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
./ipkg/rules package
|
||||
|
||||
$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
|
||||
$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
|
||||
$(IPKG) install $(PKG_IPK)
|
||||
|
||||
source: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
prepare: $(PKG_BUILD_DIR)/ipkg/rules
|
||||
compile: $(PKG_IPK)
|
||||
install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
|
||||
install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
|
||||
|
||||
clean:
|
||||
-cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
clean
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
./ipkg/rules clean
|
||||
rm -rf $(PKG_BUILD_DIR)
|
||||
rm -f $(PKG_IPK)
|
||||
|
||||
|
@ -1,179 +0,0 @@
|
||||
diff -ruN dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/CONTROL/conffiles dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/CONTROL/conffiles
|
||||
--- dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/CONTROL/conffiles 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/CONTROL/conffiles 2005-03-09 06:20:12.000000000 +0100
|
||||
@@ -0,0 +1 @@
|
||||
+/etc/dhcp-fwd.conf
|
||||
diff -ruN dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/CONTROL/control dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/CONTROL/control
|
||||
--- dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/CONTROL/control 2005-03-09 06:33:30.000000000 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+Package: dhcp-forwarder
|
||||
+Priority: optional
|
||||
+Section: net
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/dhcp-forwarder/
|
||||
+Description: a DHCP relay agent
|
||||
diff -ruN dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/etc/init.d/dhcp-fwd dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/etc/init.d/dhcp-fwd
|
||||
--- dhcp-forwarder-0.7-orig/ipkg/dhcp-forwarder/etc/init.d/dhcp-fwd 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ dhcp-forwarder-0.7-4/ipkg/dhcp-forwarder/etc/init.d/dhcp-fwd 2005-03-09 10:43:02.000000000 +0100
|
||||
@@ -0,0 +1,21 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
+LOG_D=/var/log
|
||||
+RUN_D=/var/run
|
||||
+PID_F=$RUN_D/dhcpd-fwd.pid
|
||||
+
|
||||
+case $1 in
|
||||
+ start)
|
||||
+ [ -d $LOG_D ] || mkdir -p $LOG_D
|
||||
+ [ -d $RUN_D ] || mkdir -p $RUN_D
|
||||
+ dhcp-fwd >/dev/null 2>&1
|
||||
+ ;;
|
||||
+ stop)
|
||||
+ [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
|
||||
+ ;;
|
||||
+ *)
|
||||
+ echo "usage: $0 (start|stop)"
|
||||
+ exit 1
|
||||
+esac
|
||||
+
|
||||
+exit $?
|
||||
diff -ruN dhcp-forwarder-0.7-orig/ipkg/rules dhcp-forwarder-0.7-4/ipkg/rules
|
||||
--- dhcp-forwarder-0.7-orig/ipkg/rules 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ dhcp-forwarder-0.7-4/ipkg/rules 2005-03-13 13:07:27.000000000 +0100
|
||||
@@ -0,0 +1,128 @@
|
||||
+#!/usr/bin/make -f
|
||||
+
|
||||
+ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
+ include $(IPKG_RULES_INC)
|
||||
+endif
|
||||
+
|
||||
+##
|
||||
+
|
||||
+PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
+CURRENT_DIR := $(shell pwd)
|
||||
+INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
|
||||
+
|
||||
+unexport INSTALL_DIR
|
||||
+
|
||||
+I_DHCP_FORWARDER := ipkg/dhcp-forwarder
|
||||
+
|
||||
+BUILD_DEPS := \
|
||||
+
|
||||
+CONFIGURE_OPTS = \
|
||||
+
|
||||
+##
|
||||
+
|
||||
+all: package
|
||||
+
|
||||
+
|
||||
+.stamp-configured: $(BUILD_DEPS)
|
||||
+
|
||||
+ rm -rf config.cache
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
|
||||
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
+ ac_cv_func_malloc_0_nonnull="yes" \
|
||||
+ ./configure \
|
||||
+ --target=$(GNU_TARGET_NAME) \
|
||||
+ --host=$(GNU_TARGET_NAME) \
|
||||
+ --build=$(GNU_HOST_NAME) \
|
||||
+ --program-prefix="" \
|
||||
+ --program-suffix="" \
|
||||
+ --prefix=/usr \
|
||||
+ --exec-prefix=/usr \
|
||||
+ --bindir=/usr/bin \
|
||||
+ --datadir=/usr/share \
|
||||
+ --includedir=/usr/include \
|
||||
+ --infodir=/usr/share/info \
|
||||
+ --libdir=/usr/lib \
|
||||
+ --libexecdir=/usr/lib \
|
||||
+ --localstatedir=/var \
|
||||
+ --mandir=/usr/share/man \
|
||||
+ --sbindir=/usr/sbin \
|
||||
+ --sysconfdir=/etc \
|
||||
+ $(DISABLE_LARGEFILE) \
|
||||
+ $(DISABLE_NLS) \
|
||||
+ $(CONFIGURE_OPTS) \
|
||||
+
|
||||
+ touch .stamp-configured
|
||||
+
|
||||
+
|
||||
+.stamp-built: .stamp-configured
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ cfg_filename="/etc/dhcp-fwd.conf" \
|
||||
+
|
||||
+ touch .stamp-built
|
||||
+
|
||||
+
|
||||
+$(INSTALL_DIR)/usr/sbin/dhcp-fwd: .stamp-built
|
||||
+
|
||||
+ mkdir -p $(INSTALL_DIR)
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ DESTDIR="$(INSTALL_DIR)" \
|
||||
+ install
|
||||
+
|
||||
+
|
||||
+configure: .stamp-configured
|
||||
+
|
||||
+
|
||||
+build: .stamp-built
|
||||
+
|
||||
+
|
||||
+install: $(INSTALL_DIR)/usr/sbin/dhcp-fwd
|
||||
+
|
||||
+
|
||||
+package: $(INSTALL_DIR)/usr/sbin/dhcp-fwd
|
||||
+
|
||||
+ mkdir -p $(I_DHCP_FORWARDER)/etc
|
||||
+ cp -fpR contrib/dhcp-fwd.conf $(I_DHCP_FORWARDER)/etc/
|
||||
+
|
||||
+ mkdir -p $(I_DHCP_FORWARDER)/usr/sbin
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/sbin/dhcp-fwd $(I_DHCP_FORWARDER)/usr/sbin/
|
||||
+ $(STRIP) $(I_DHCP_FORWARDER)/usr/sbin/*
|
||||
+
|
||||
+ chmod 0755 $(I_DHCP_FORWARDER)/etc/
|
||||
+ chmod 0600 $(I_DHCP_FORWARDER)/etc/dhcp-fwd.conf
|
||||
+ chmod 0755 $(I_DHCP_FORWARDER)/etc/init.d/
|
||||
+ chmod 0755 $(I_DHCP_FORWARDER)/etc/init.d/dhcp-fwd
|
||||
+
|
||||
+ chmod 0755 ipkg/*/CONTROL/
|
||||
+ chmod 0644 ipkg/*/CONTROL/control
|
||||
+ -chmod 0644 ipkg/*/CONTROL/conffiles
|
||||
+
|
||||
+ perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
+ifneq ($(strip $(PKG_VERSION)),)
|
||||
+ perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
+endif
|
||||
+
|
||||
+ $(IPKG_BUILD) $(I_DHCP_FORWARDER) $(IPKG_TARGET_DIR)
|
||||
+
|
||||
+
|
||||
+clean:
|
||||
+
|
||||
+ -$(MAKE) \
|
||||
+ DESTDIR="$(INSTALL_DIR)" \
|
||||
+ uninstall clean
|
||||
+
|
||||
+ rm -rf .stamp-* \
|
||||
+ $(I_DHCP_FORWARDER)/etc/dhcp-fwd.conf \
|
||||
+ $(I_DHCP_FORWARDER)/usr \
|
||||
+
|
||||
+
|
||||
+control:
|
||||
+
|
||||
+ @cat $(I_DHCP_FORWARDER)/CONTROL/control
|
||||
+ @echo
|
||||
+
|
||||
+
|
||||
+.PHONY: configure build install package clean control
|
||||
diff -ruN dhcp-forwarder-0.7-orig/ipkg/version dhcp-forwarder-0.7-4/ipkg/version
|
||||
--- dhcp-forwarder-0.7-orig/ipkg/version 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ dhcp-forwarder-0.7-4/ipkg/version 2005-03-09 06:22:11.000000000 +0100
|
||||
@@ -0,0 +1 @@
|
||||
+0.7-4
|
@ -0,0 +1 @@
|
||||
/etc/dhcp-fwd.conf
|
@ -0,0 +1,8 @@
|
||||
Package: dhcp-forwarder
|
||||
Priority: optional
|
||||
Section: net
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/dhcp-forwarder/
|
||||
Description: a DHCP relay agent
|
@ -0,0 +1,21 @@
|
||||
#!/bin/sh
|
||||
|
||||
LOG_D=/var/log
|
||||
RUN_D=/var/run
|
||||
PID_F=$RUN_D/dhcpd-fwd.pid
|
||||
|
||||
case $1 in
|
||||
start)
|
||||
[ -d $LOG_D ] || mkdir -p $LOG_D
|
||||
[ -d $RUN_D ] || mkdir -p $RUN_D
|
||||
dhcp-fwd >/dev/null 2>&1
|
||||
;;
|
||||
stop)
|
||||
[ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 (start|stop)"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit $?
|
128
openwrt/package/dhcp-forwarder/ipkg/rules
Normal file
128
openwrt/package/dhcp-forwarder/ipkg/rules
Normal file
@ -0,0 +1,128 @@
|
||||
#!/usr/bin/make -f
|
||||
|
||||
ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
include $(IPKG_RULES_INC)
|
||||
endif
|
||||
|
||||
##
|
||||
|
||||
PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
CURRENT_DIR := $(shell pwd)
|
||||
INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
|
||||
|
||||
unexport INSTALL_DIR
|
||||
|
||||
I_DHCP_FORWARDER := ipkg/dhcp-forwarder
|
||||
|
||||
BUILD_DEPS := \
|
||||
|
||||
CONFIGURE_OPTS = \
|
||||
|
||||
##
|
||||
|
||||
all: package
|
||||
|
||||
|
||||
.stamp-configured: $(BUILD_DEPS)
|
||||
|
||||
rm -rf config.cache
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
ac_cv_func_malloc_0_nonnull="yes" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
$(CONFIGURE_OPTS) \
|
||||
|
||||
touch .stamp-configured
|
||||
|
||||
|
||||
.stamp-built: .stamp-configured
|
||||
|
||||
$(MAKE) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
cfg_filename="/etc/dhcp-fwd.conf" \
|
||||
|
||||
touch .stamp-built
|
||||
|
||||
|
||||
$(INSTALL_DIR)/usr/sbin/dhcp-fwd: .stamp-built
|
||||
|
||||
mkdir -p $(INSTALL_DIR)
|
||||
|
||||
$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
install
|
||||
|
||||
|
||||
configure: .stamp-configured
|
||||
|
||||
|
||||
build: .stamp-built
|
||||
|
||||
|
||||
install: $(INSTALL_DIR)/usr/sbin/dhcp-fwd
|
||||
|
||||
|
||||
package: $(INSTALL_DIR)/usr/sbin/dhcp-fwd
|
||||
|
||||
mkdir -p $(I_DHCP_FORWARDER)/etc
|
||||
cp -fpR contrib/dhcp-fwd.conf $(I_DHCP_FORWARDER)/etc/
|
||||
|
||||
mkdir -p $(I_DHCP_FORWARDER)/usr/sbin
|
||||
cp -fpR $(INSTALL_DIR)/usr/sbin/dhcp-fwd $(I_DHCP_FORWARDER)/usr/sbin/
|
||||
$(STRIP) $(I_DHCP_FORWARDER)/usr/sbin/*
|
||||
|
||||
chmod 0755 $(I_DHCP_FORWARDER)/etc/
|
||||
chmod 0600 $(I_DHCP_FORWARDER)/etc/dhcp-fwd.conf
|
||||
chmod 0755 $(I_DHCP_FORWARDER)/etc/init.d/
|
||||
chmod 0755 $(I_DHCP_FORWARDER)/etc/init.d/dhcp-fwd
|
||||
|
||||
chmod 0755 ipkg/*/CONTROL/
|
||||
chmod 0644 ipkg/*/CONTROL/control
|
||||
-chmod 0644 ipkg/*/CONTROL/conffiles
|
||||
|
||||
perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
ifneq ($(strip $(PKG_VERSION)),)
|
||||
perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
endif
|
||||
|
||||
$(IPKG_BUILD) $(I_DHCP_FORWARDER) $(IPKG_TARGET_DIR)
|
||||
|
||||
|
||||
clean:
|
||||
|
||||
-$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
uninstall clean
|
||||
|
||||
rm -rf .stamp-* \
|
||||
$(I_DHCP_FORWARDER)/etc/dhcp-fwd.conf \
|
||||
$(I_DHCP_FORWARDER)/usr \
|
||||
|
||||
|
||||
control:
|
||||
|
||||
@cat $(I_DHCP_FORWARDER)/CONTROL/control
|
||||
@echo
|
||||
|
||||
|
||||
.PHONY: configure build install package clean control
|
1
openwrt/package/dhcp-forwarder/ipkg/version
Normal file
1
openwrt/package/dhcp-forwarder/ipkg/version
Normal file
@ -0,0 +1 @@
|
||||
0.7-4
|
Loading…
Reference in New Issue
Block a user