Change ncurses packaging
SVN-Revision: 487
This commit is contained in:
parent
902f880364
commit
9038faa018
@ -27,16 +27,15 @@ $(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||
$(PKG_BUILD_DIR)/ipkg/rules: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
mkdir -p $(TOOL_BUILD_DIR)
|
||||
$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(PATCH) $(PKG_BUILD_DIR) . $(PKG_NAME)-\*.diff
|
||||
# $(PATCH) $(PKG_BUILD_DIR) ./patches
|
||||
cp -fpR ./ipkg $(PKG_BUILD_DIR)/
|
||||
chmod a+x $(PKG_BUILD_DIR)/ipkg/rules
|
||||
|
||||
$(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
|
||||
cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" \
|
||||
IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
package
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
./ipkg/rules package
|
||||
|
||||
$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
|
||||
$(IPKG) install $(PKG_IPK)
|
||||
@ -48,9 +47,8 @@ install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
|
||||
|
||||
clean:
|
||||
-cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
clean
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
./ipkg/rules clean
|
||||
rm -rf $(PKG_BUILD_DIR)
|
||||
rm -r $(PKG_IPK)
|
||||
rm -f $(PKG_IPK)
|
||||
|
@ -0,0 +1,8 @@
|
||||
Package: libncurses-dev
|
||||
Priority: optional
|
||||
Section: devel
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
Description: a terminal handling library (development)
|
8
openwrt/package/ncurses/ipkg/libncurses/CONTROL/control
Normal file
8
openwrt/package/ncurses/ipkg/libncurses/CONTROL/control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: libncurses
|
||||
Priority: optional
|
||||
Section: libs
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
Description: a terminal handling library
|
@ -0,0 +1,9 @@
|
||||
Package: ncurses-term
|
||||
Priority: optional
|
||||
Section: admin
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
Description: common terminal definitions
|
||||
Depends: libncurses
|
161
openwrt/package/ncurses/ipkg/rules
Normal file
161
openwrt/package/ncurses/ipkg/rules
Normal file
@ -0,0 +1,161 @@
|
||||
#!/usr/bin/make -f
|
||||
|
||||
ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
include $(IPKG_RULES_INC)
|
||||
endif
|
||||
|
||||
##
|
||||
|
||||
PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
CURRENT_DIR := $(shell pwd)
|
||||
INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
|
||||
|
||||
unexport INSTALL_DIR
|
||||
|
||||
I_LIBNCURSES := ipkg/libncurses
|
||||
I_LIBNCURSES_DEV := ipkg/libncurses-dev
|
||||
I_NCURSES_TERM := ipkg/ncurses-term
|
||||
|
||||
BUILD_DEPS := \
|
||||
|
||||
CONFIGURE_OPTS = \
|
||||
--with-terminfo-dirs=/usr/share/terminfo \
|
||||
--with-default-terminfo-dir=/usr/share/terminfo \
|
||||
--without-ada \
|
||||
--without-cxx \
|
||||
--without-cxx-binding \
|
||||
--without-progs \
|
||||
--without-profile \
|
||||
--without-debug \
|
||||
--disable-rpath \
|
||||
--enable-echo \
|
||||
--enable-const \
|
||||
--enable-overwrite \
|
||||
--with-shared \
|
||||
--with-normal \
|
||||
##
|
||||
|
||||
all: package
|
||||
|
||||
|
||||
.stamp-configured: $(BUILD_DEPS)
|
||||
|
||||
rm -rf config.cache
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
ac_cv_linux_vers="2" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
$(CONFIGURE_OPTS) \
|
||||
|
||||
touch .stamp-configured
|
||||
|
||||
|
||||
.stamp-built: .stamp-configured
|
||||
|
||||
$(MAKE) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
BUILD_CC="$(TARGET_CROSS)gcc" \
|
||||
HOSTCC="$(HOSTCC)" \
|
||||
HOSTCCFLAGS="\$$(CPPFLAGS)" \
|
||||
|
||||
touch .stamp-built
|
||||
|
||||
|
||||
$(INSTALL_DIR)/usr/include/ncurses.h: .stamp-built
|
||||
|
||||
mkdir -p $(INSTALL_DIR)
|
||||
|
||||
$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
install
|
||||
|
||||
|
||||
configure: .stamp-configured
|
||||
|
||||
|
||||
build: .stamp-built
|
||||
|
||||
|
||||
install: $(INSTALL_DIR)/usr/include/ncurses.h
|
||||
|
||||
|
||||
package: $(INSTALL_DIR)/usr/include/ncurses.h
|
||||
|
||||
mkdir -p $(I_LIBNCURSES)/usr/lib
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libncurses*.so.* $(I_LIBNCURSES)/usr/lib/
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpanel*.so.* $(I_LIBNCURSES)/usr/lib/
|
||||
$(STRIP) $(I_LIBNCURSES)/usr/lib/*
|
||||
|
||||
mkdir -p $(I_LIBNCURSES_DEV)/usr/include
|
||||
cp -fpR $(INSTALL_DIR)/usr/include/curses.h $(I_LIBNCURSES_DEV)/usr/include/
|
||||
cp -fpR $(INSTALL_DIR)/usr/include/ncurses.h $(I_LIBNCURSES_DEV)/usr/include/
|
||||
cp -fpR $(INSTALL_DIR)/usr/include/panel.h $(I_LIBNCURSES_DEV)/usr/include/
|
||||
mkdir -p $(I_LIBNCURSES_DEV)/usr/lib
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libncurses.a $(I_LIBNCURSES_DEV)/usr/lib/
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpanel.a $(I_LIBNCURSES_DEV)/usr/lib/
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libncurses*.so* $(I_LIBNCURSES_DEV)/usr/lib/
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpanel*.so* $(I_LIBNCURSES_DEV)/usr/lib/
|
||||
|
||||
mkdir -p $(I_NCURSES_TERM)/usr/share/terminfo
|
||||
for f in a/ansi d/dumb l/linux s/screen v/vt100; do \
|
||||
mkdir -p $(I_NCURSES_TERM)/usr/share/terminfo/`dirname $${f}`; \
|
||||
cp -fpR \
|
||||
$(INSTALL_DIR)/usr/share/terminfo/$${f} \
|
||||
$(I_NCURSES_TERM)/usr/share/terminfo/$${f}; \
|
||||
done
|
||||
|
||||
chmod 0755 ipkg/*/CONTROL/
|
||||
chmod 0644 ipkg/*/CONTROL/control
|
||||
|
||||
perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
ifneq ($(strip $(PKG_VERSION)),)
|
||||
perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
endif
|
||||
|
||||
$(IPKG_BUILD) $(I_LIBNCURSES) $(IPKG_TARGET_DIR)
|
||||
$(IPKG_BUILD) $(I_LIBNCURSES_DEV) $(IPKG_TARGET_DIR)
|
||||
$(IPKG_BUILD) $(I_NCURSES_TERM) $(IPKG_TARGET_DIR)
|
||||
|
||||
|
||||
clean:
|
||||
|
||||
-$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
uninstall clean
|
||||
|
||||
rm -rf .stamp-* \
|
||||
$(I_LIBNCURSES)/usr \
|
||||
$(I_LIBNCURSES_DEV)/usr \
|
||||
$(I_NCURSES_TERM)/usr \
|
||||
|
||||
|
||||
control:
|
||||
|
||||
@cat $(I_LIBNCURSES)/CONTROL/control
|
||||
@echo
|
||||
@cat $(I_LIBNCURSES_DEV)/CONTROL/control
|
||||
@echo
|
||||
@cat $(I_NCURSES_TERM)/CONTROL/control
|
||||
@echo
|
||||
|
||||
|
||||
.PHONY: configure build install package clean control
|
1
openwrt/package/ncurses/ipkg/version
Normal file
1
openwrt/package/ncurses/ipkg/version
Normal file
@ -0,0 +1 @@
|
||||
5.2-6
|
@ -1,212 +0,0 @@
|
||||
diff -ruN ncurses-5.2-orig/ipkg/libncurses/CONTROL/control ncurses-5.2-5/ipkg/libncurses/CONTROL/control
|
||||
--- ncurses-5.2-orig/ipkg/libncurses/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ncurses-5.2-5/ipkg/libncurses/CONTROL/control 2005-03-06 22:47:47.000000000 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+Package: libncurses
|
||||
+Priority: optional
|
||||
+Section: libs
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
+Description: a terminal handling library
|
||||
diff -ruN ncurses-5.2-orig/ipkg/ncurses-dev/CONTROL/control ncurses-5.2-5/ipkg/ncurses-dev/CONTROL/control
|
||||
--- ncurses-5.2-orig/ipkg/ncurses-dev/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ncurses-5.2-5/ipkg/ncurses-dev/CONTROL/control 2005-03-06 22:47:39.000000000 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+Package: ncurses-dev
|
||||
+Priority: optional
|
||||
+Section: devel
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
+Description: a terminal handling library (development)
|
||||
diff -ruN ncurses-5.2-orig/ipkg/ncurses-term/CONTROL/control ncurses-5.2-5/ipkg/ncurses-term/CONTROL/control
|
||||
--- ncurses-5.2-orig/ipkg/ncurses-term/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ncurses-5.2-5/ipkg/ncurses-term/CONTROL/control 2005-03-06 22:47:55.000000000 +0100
|
||||
@@ -0,0 +1,9 @@
|
||||
+Package: ncurses-term
|
||||
+Priority: optional
|
||||
+Section: admin
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/ncurses/
|
||||
+Description: common terminal definitions
|
||||
+Depends: libncurses
|
||||
diff -ruN ncurses-5.2-orig/ipkg/rules ncurses-5.2-5/ipkg/rules
|
||||
--- ncurses-5.2-orig/ipkg/rules 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ncurses-5.2-5/ipkg/rules 2005-03-08 05:14:46.000000000 +0100
|
||||
@@ -0,0 +1,154 @@
|
||||
+#!/usr/bin/make -f
|
||||
+
|
||||
+ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
+ include $(IPKG_RULES_INC)
|
||||
+endif
|
||||
+
|
||||
+##
|
||||
+
|
||||
+PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
+CURRENT_DIR := $(shell pwd)
|
||||
+INSTALL_DIR = $(CURRENT_DIR)/ipkg-install
|
||||
+
|
||||
+I_LIBNCURSES := ipkg/libncurses
|
||||
+I_NCURSES_DEV := ipkg/ncurses-dev
|
||||
+I_NCURSES_TERM := ipkg/ncurses-term
|
||||
+
|
||||
+BUILD_DEPS := \
|
||||
+
|
||||
+CONFIGURE_OPTS = \
|
||||
+ --with-terminfo-dirs=/usr/share/terminfo \
|
||||
+ --with-default-terminfo-dir=/usr/share/terminfo \
|
||||
+ --without-ada \
|
||||
+ --without-cxx \
|
||||
+ --without-cxx-binding \
|
||||
+ --without-progs \
|
||||
+ --without-profile \
|
||||
+ --without-debug \
|
||||
+ --disable-rpath \
|
||||
+ --enable-echo \
|
||||
+ --enable-const \
|
||||
+ --enable-overwrite \
|
||||
+ --with-shared \
|
||||
+ --with-normal \
|
||||
+##
|
||||
+
|
||||
+all: package
|
||||
+
|
||||
+
|
||||
+.stamp-configured: $(BUILD_DEPS)
|
||||
+
|
||||
+ rm -rf config.cache
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ CFLAGS="$(TARGET_CFLAGS)" \
|
||||
+ ac_cv_linux_vers="2" \
|
||||
+ ./configure \
|
||||
+ --target=$(GNU_TARGET_NAME) \
|
||||
+ --host=$(GNU_TARGET_NAME) \
|
||||
+ --build=$(GNU_HOST_NAME) \
|
||||
+ --prefix=/usr \
|
||||
+ --exec-prefix=/usr \
|
||||
+ --bindir=/usr/bin \
|
||||
+ --datadir=/usr/share \
|
||||
+ --includedir=/usr/include \
|
||||
+ --infodir=/usr/share/info \
|
||||
+ --libdir=/usr/lib \
|
||||
+ --libexecdir=/usr/lib \
|
||||
+ --localstatedir=/var \
|
||||
+ --mandir=/usr/share/man \
|
||||
+ --sbindir=/usr/sbin \
|
||||
+ --sysconfdir=/etc \
|
||||
+ $(DISABLE_NLS) \
|
||||
+ $(CONFIGURE_OPTS) \
|
||||
+
|
||||
+ touch .stamp-configured
|
||||
+
|
||||
+
|
||||
+.stamp-built: .stamp-configured
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ BUILD_CC=$(TARGET_CC) \
|
||||
+ HOSTCC=$(HOSTCC) \
|
||||
+
|
||||
+ touch .stamp-built
|
||||
+
|
||||
+
|
||||
+$(INSTALL_DIR)/usr/include/ncurses.h: .stamp-built
|
||||
+
|
||||
+ mkdir -p $(INSTALL_DIR)
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ DESTDIR="$(INSTALL_DIR)" \
|
||||
+ install
|
||||
+
|
||||
+
|
||||
+configure: .stamp-configured
|
||||
+
|
||||
+
|
||||
+build: .stamp-built
|
||||
+
|
||||
+
|
||||
+install: $(INSTALL_DIR)/usr/include/ncurses.h
|
||||
+
|
||||
+
|
||||
+package: $(INSTALL_DIR)/usr/include/ncurses.h
|
||||
+
|
||||
+ mkdir -p $(I_LIBNCURSES)/usr/lib
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libncurses*.so.* $(I_LIBNCURSES)/usr/lib/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpanel*.so.* $(I_LIBNCURSES)/usr/lib/
|
||||
+ $(STRIP) $(I_LIBNCURSES)/usr/lib/*
|
||||
+
|
||||
+ mkdir -p $(I_NCURSES_DEV)/usr/include
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/include/curses.h $(I_NCURSES_DEV)/usr/include/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/include/ncurses.h $(I_NCURSES_DEV)/usr/include/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/include/panel.h $(I_NCURSES_DEV)/usr/include/
|
||||
+ mkdir -p $(I_NCURSES_DEV)/usr/lib
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libncurses.a $(I_NCURSES_DEV)/usr/lib/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpanel.a $(I_NCURSES_DEV)/usr/lib/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libncurses*.so* $(I_NCURSES_DEV)/usr/lib/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpanel*.so* $(I_NCURSES_DEV)/usr/lib/
|
||||
+
|
||||
+ mkdir -p $(I_NCURSES_TERM)/usr/share/terminfo
|
||||
+ for f in a/ansi d/dumb l/linux s/screen v/vt100; do \
|
||||
+ mkdir -p $(I_NCURSES_TERM)/usr/share/terminfo/`dirname $${f}`; \
|
||||
+ cp -fpR \
|
||||
+ $(INSTALL_DIR)/usr/share/terminfo/$${f} \
|
||||
+ $(I_NCURSES_TERM)/usr/share/terminfo/$${f}; \
|
||||
+ done
|
||||
+
|
||||
+ chmod 0755 ipkg/*/CONTROL/
|
||||
+ chmod 0644 ipkg/*/CONTROL/control
|
||||
+
|
||||
+ perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
+ifneq ($(strip $(PKG_VERSION)),)
|
||||
+ perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
+endif
|
||||
+
|
||||
+ $(IPKG_BUILD) $(I_LIBNCURSES) $(IPKG_TARGET_DIR)
|
||||
+ $(IPKG_BUILD) $(I_NCURSES_DEV) $(IPKG_TARGET_DIR)
|
||||
+ $(IPKG_BUILD) $(I_NCURSES_TERM) $(IPKG_TARGET_DIR)
|
||||
+
|
||||
+
|
||||
+clean:
|
||||
+
|
||||
+ -$(MAKE) \
|
||||
+ DESTDIR="$(INSTALL_DIR)" \
|
||||
+ uninstall clean
|
||||
+ rm -rf .stamp-*
|
||||
+ rm -rf $(I_LIBNCURSES)/usr
|
||||
+ rm -rf $(I_NCURSES_DEV)/usr
|
||||
+ rm -rf $(I_NCURSES_TERM)/usr
|
||||
+
|
||||
+
|
||||
+control:
|
||||
+
|
||||
+ @cat $(I_LIBNCURSES)/CONTROL/control
|
||||
+ @echo
|
||||
+ @cat $(I_NCURSES_DEV)/CONTROL/control
|
||||
+ @echo
|
||||
+ @cat $(I_NCURSES_TERM)/CONTROL/control
|
||||
+ @echo
|
||||
+
|
||||
+
|
||||
+.PHONY: configure build install package clean control
|
||||
diff -ruN ncurses-5.2-orig/ipkg/version ncurses-5.2-5/ipkg/version
|
||||
--- ncurses-5.2-orig/ipkg/version 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ncurses-5.2-5/ipkg/version 2005-03-06 22:43:28.000000000 +0100
|
||||
@@ -0,0 +1 @@
|
||||
+5.2-5
|
||||
diff -ruN ncurses-5.2-orig/ncurses/Makefile.in ncurses-5.2-5/ncurses/Makefile.in
|
||||
--- ncurses-5.2-orig/ncurses/Makefile.in 2000-10-15 00:55:35.000000000 +0200
|
||||
+++ ncurses-5.2-5/ncurses/Makefile.in 2005-03-06 22:36:45.000000000 +0100
|
||||
@@ -85,7 +85,7 @@
|
||||
CCFLAGS = $(CPPFLAGS) $(CFLAGS)
|
||||
|
||||
HOSTCC = @BUILD_CC@
|
||||
-HOSTCCFLAGS = @CFLAGS@ $(CPPFLAGS)
|
||||
+HOSTCCFLAGS = $(CPPFLAGS)
|
||||
HOSTLDFLAGS = @LDFLAGS@ @LIBS@
|
||||
|
||||
CFLAGS_LIBTOOL = $(CCFLAGS)
|
Loading…
Reference in New Issue
Block a user